XAMPP : régler le problème de lancement d’Apache sous Windows 10

XAMPP2

Windows 10 est le dernier né des OS de Microsoft. Comme à chaque fois, certains décident (comme moi) de se lancer et d’installer la dernière version sur sa machine. Et c’est là que les ennuis commencent !
Je ne rentrerai pas dans les détails en ce qui concerne les différents problèmes que l’on peut rencontrer sur cette dernière version sauf un qui me paraît assez gênant: l'erreur de lancement d’Apache sous XAMPP.

WordPress 3.8 est arrivé !

Depuis la semaine dernière, WordPress 3.8 est enfin disponible. Cette version comporte de nouvelles fonctionnalités intéressantes essentiellement basées sur l’affichage.

Grâce au développement responsive réalisé sur cette nouvelle version, les utilisateurs de WordPress vont pouvoir désormais mettre à jour le contenu de leurs sites Web avec plus d’aisance et de facilité, cela directement avec l’aide de leur tablette et voire même de leur Smartphone. L’affichage s’adaptera de manière cohérente et organisée selon l’appareil que vous utilisez. wordpress-une-nouvelle-interface-dadministration-arrive-avec-la-version-3-8.png

Il faut également noter l’ajout d’un nouveau thème par défaut lui aussi responsive, Twenty Fourteen.

Grâce à ces améliorations, le temps de chargement des pages a été réduit, les contrastes affinés et la typographie est devenue plus nette. Ainsi WordPress est doté d’une interface plus esthétique et moderne.

Pour les intéressés, cliquez ici pour visualiser une vidéo présentant le nouveau thème par défaut ajouté à la version 3.8.

La balise #TRI sous SPIP 3

La nouvelle version de SPIP 3.0 est sortie depuis quelques mois. Celle-ci a son lot de nouvelles fonctionnalités dont une qui me paraît très pratique et facile à mettre en place, la balise #TRI. Elle permet tout simplement de créer un menu de tri pour l’affichage d’une liste d'articles, ou d'un autre type de contenu.

Pour ajouter cette fonctionnalité, il suffit de créer une boucle ARTICLES comme celle-ci : tri1.jpg

Le code entouré en rouge correspond au mécanisme mis en place pour l’affichage du menu de tri. On peut trier le contenu de plusieurs manières et pas seulement par date ou par titre ! Pour obtenir par défaut un tri croissant, il faut rajouter le critère 1 ou direct de cette manière {tri date, 1}, et -1 ou inverse pour un tri décroissant.

Pour ne pas recharger la page entièrement mais seulement de manière partielle, il est possible de rajouter le paramètre ajax en 3ème argument de la balise #TRI.

Grâce à cette nouvelle fonctionnalité, plus besoin de dupliquer la boucle en y ajoutant un ordre d’affichage différent pour permettre à l’utilisateur de trier le contenu sur la page. Voici le résultat obtenu : tri2.jpg

SPIP 3.0 est officiellement sorti!

logospip

Pour rappeler brièvement, SPIP est un CMS qui permet de publier de manière simple et intuitive du contenu éditorial sur internet. Cette nouvelle version 3.0 (v3.0.1) qui a vu le jour ce weekend a été repensée, améliorée, avec de nouvelles fonctionnalités :

  • Une boucle DATA permettant de récupérer des informations émanant de plusieurs types de données tels que du XML, CSV ou encore du YAML.
  • Une évolution de l’interface d’administration (photo ci-dessous): un affichage plus épuré et agréable, ainsi qu’un regroupement plus intelligent des anciennes et nouvelles fonctionnalités.

menu

  • De nouvelles fonctionnalités de différents plugins ont été directement implantées en natifs comme le multilingue pour les rubriques, les articles et les brèves ou encore la désactivation du cache facilitant les phases de test lors du développement.
  • L’apparition d’une nouvelle balise #TRI qui permet dans une boucle de charger automatiquement un système de tri à l’aide du critère {tri …}. Ainsi il sera facile de proposer à l’utilisateur un menu pour trier le contenu affiché sur une page.
  • De nouveaux filtres sont à noter comme |balise_img permettant de générer une balise img en utilisant la balise #CHEMIN.
  • JQuery a été mise à jour (v1.7.2) et JQUERY UI est enfin présent en natif en version 1.8.20.

Ceci ne représente qu’une partie des mises à jour de cette nouvelle version majeure de SPIP.

Il est important de noter que le support de la version 1.9.2 et antérieures est définitivement arrêté et que la nouvelle version ne supporte plus le PHP 4. Le minimum requis est désormais PHP 5.1.0.

Remarque: Il est conseillé d’attendre quelques mois avant d’utiliser cette version 3.0 pour vos nouveaux sites ou pour ceux que vous souhaitez migrer. Il n’est pas rare que des bugs et d’importantes failles de sécurité soient détectés au début de l’existence de chaque nouvelle version. De ce fait ne vous précipitez pas pour l'installer!